With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
Pre SG 1.0 archive

Postby Tequila » Sun Nov 16, 2008 3:38 pm

ChainLightnin' wrote:Hmm, for what it's worth, I just got the "awaiting snapshot" stoppage on both test servers. They worked fine before. :?


Yes, sorry for that but it seems server has strange behaviour... Sometime it hangs until somebody is connecting... sometime it just shut down the game (during the first 20 seconds) without starting a new game until a player connects to the server... Also I see few player connection who don't have the game... I think the server is shown in other Q3A games server list and they try to connect... maybe expecting to download the game or the map ... who knows ? That guys seems to have the GUID set... From the SG testing players, I only saw ChainSaw and maybe Tequila :P with the GUID set. I know ChainSaw tested the binary I compiled but it seems the windows binary is not compiled with the complete GUID patch I uploaded in the private FTP server... can any one check that ? Hika, did you compiled the latest windows binary ? In fact what is the status of the windows binary toward the current SVN sources ?

Btw, I restarted the server. I would have more time to check why server is hanging sometime... sorry about my missing time... I wish to have more time to debug that in the early next year :? ...

8)
User avatar
Tequila
SG Team
 
Posts: 1088
Joined: Thu Nov 15, 2007 11:33 pm
Location: Montpellier, France



Stand Alone Off Topic Trivia

Postby ChainLightnin' » Tue Nov 18, 2008 5:24 am

"Point to where our gold is, Wyatt."

Image
Well...Mr. Chain Blue Lightnin' hisself..heh, heh!
User avatar
ChainLightnin'
Gunslinger
 
Posts: 389
Joined: Fri Jun 09, 2006 4:09 am
Location: Montana



Postby ReD NeCKersoN » Tue Nov 18, 2008 7:13 am

For a minute there I was like "Huh? Where's the bug?"
Then I noticed yer subject line: Stand Alone Off Topic Trivia :D No gold in a non-br map CL! (Maybe a br version in the future. No promises.)

Heh, heh. I can give you some real bugs in that map if you like.

1) Gatling gun anywhere near moving machinery causes major weirdness. Try it & see. I have no idea how to fix it short of player clipping to the point of absurdity. :oops:

2) Problem with the whistle sound NOT triggering with bots sometimes. As best I can tell, due to a spawn conflict tied to a trigger that activates the sound file on a timer... I guess. Error appears in console if you wait long enough. Don't know about multiple players (with no bots) on a server but I assume the same result.

3) Flag has no animation. This is an annoyance rather than a bug. A shader should fix it, but i can't get it to work so far.

4) Some areaportals work & some don't. Hint brushes in places where they actually work... the rest deleted. In laymans terms, the map is optimized for improved fps but not as much as I'd like. At least it's the most optimized version so far. I guess that's something.
User avatar
ReD NeCKersoN
SG Team
 
Posts: 3245
Joined: Wed Mar 27, 2002 6:22 am
Location: VA, USA



Postby Joe Kari » Tue Nov 18, 2008 1:14 pm

3) Flag has no animation. This is an annoyance rather than a bug. A shader should fix it, but i can't get it to work so far.

Just made a USA flag+pole (md3 and shader) for you, I hope you will enjoy it ;)
It is smarter than the existing one and move nicely in the wind...

I pm you the location where to find it on our ftp server.
User avatar
Joe Kari
SG Team
 
Posts: 878
Joined: Sun Sep 16, 2007 8:44 pm
Location: France



Postby ReD NeCKersoN » Wed Nov 19, 2008 12:06 am

Thanks! I'll look at it tonight. 8)
User avatar
ReD NeCKersoN
SG Team
 
Posts: 3245
Joined: Wed Mar 27, 2002 6:22 am
Location: VA, USA



Mac build bugs?

Postby Puddytang » Sun Jan 18, 2009 5:39 am

Wow it looks great!

The only bug I noticed so far is when reloading 1 bullet at a time weapons like colt peacemaker, if you continue to hold down the reload button you can hear the sound of another shell load after the gun is already full.
Puddytang
Drifter
 
Posts: 6
Joined: Fri Mar 30, 2007 4:27 am



Postby ReD NeCKersoN » Sun Jan 18, 2009 6:00 am

Welcome back. Yeah, we know about that bug & it's been posted in one of the new sections of the forum. I'll be locking this section since we don't need it anymore. :)
User avatar
ReD NeCKersoN
SG Team
 
Posts: 3245
Joined: Wed Mar 27, 2002 6:22 am
Location: VA, USA



Previous

Return to Stand-alone Testing

Show Sidebar
Show Sidebar

User Control Panel