With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
Game server information & questions.

Moderators: Pardner, Joe Kari, TheDoctor

Smokin' guns dependencies needed in linux

Postby hellraiser » Sun Oct 30, 2011 11:09 pm

Excuse me, since I can't find anywhere :oops: I have a simple question:

what are the dependencies needed to run the game in linux?

Could you please post a list of them here (libraries an so on?)

Thanks

:)
hellraiser
Quick Draw
 
Posts: 63
Joined: Sun Jul 03, 2011 2:37 pm
Location: Italy



Re: Smokin' guns dependencies needed in linux

Postby TheDoctor » Mon Oct 31, 2011 8:25 pm

hellraiser wrote:What are the dependencies needed to run the game in linux?

Could you please post a list of them here (libraries an so on?)

Among the direct dependencies are opengl, openal and libsdl.
> ldd -v smokinguns.x86
linux-gate.so.1 => (0xb77ab000)
libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0xb771e000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7704000)
libGL.so.1 => /usr/lib/opengl/xorg-x11/lib/libGL.so.1 (0xb76b7000)
librt.so.1 => /lib/librt.so.1 (0xb76ae000)
libm.so.6 => /lib/libm.so.6 (0xb7686000)
libc.so.6 => /lib/libc.so.6 (0xb74fd000)
libasound.so.2 => /usr/lib/libasound.so.2 (0xb743a000)
libdl.so.2 => /lib/libdl.so.2 (0xb7436000)
/lib/ld-linux.so.2 (0xb77ac000)
libglapi.so.0 => /usr/lib/libglapi.so.0 (0xb7421000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb740f000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb740b000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7405000)
libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb73ff000)
libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0xb73fc000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb72d8000)
libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0xb72c4000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb72a9000)
libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb729e000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb729a000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7294000)

Version information:
./smokinguns.x86:
librt.so.1 (GLIBC_2.2) => /lib/librt.so.1
libm.so.6 (GLIBC_2.0) => /lib/libm.so.6
libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.7) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libSDL-1.2.so.0:
libdl.so.2 (GLIBC_2.1) => /lib/libdl.so.2
libdl.so.2 (GLIBC_2.0) => /lib/libdl.so.2
libm.so.6 (GLIBC_2.0) => /lib/libm.so.6
libasound.so.2 (ALSA_0.9.0rc4) => /usr/lib/libasound.so.2
libasound.so.2 (ALSA_0.9) => /usr/lib/libasound.so.2
libpthread.so.0 (GLIBC_2.1) => /lib/libpthread.so.0
libpthread.so.0 (GLIBC_2.3.2) => /lib/libpthread.so.0
libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/lib/libpthread.so.0:
ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/opengl/xorg-x11/lib/libGL.so.1:
libdl.so.2 (GLIBC_2.1) => /lib/libdl.so.2
libdl.so.2 (GLIBC_2.0) => /lib/libdl.so.2
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
/lib/librt.so.1:
ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
libpthread.so.0 (GLIBC_2.1) => /lib/libpthread.so.0
libpthread.so.0 (GLIBC_2.2) => /lib/libpthread.so.0
libpthread.so.0 (GLIBC_PRIVATE) => /lib/libpthread.so.0
libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/lib/libm.so.6:
ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/lib/libc.so.6:
ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
/usr/lib/libasound.so.2:
librt.so.1 (GLIBC_2.2) => /lib/librt.so.1
libdl.so.2 (GLIBC_2.1) => /lib/libdl.so.2
libdl.so.2 (GLIBC_2.0) => /lib/libdl.so.2
libm.so.6 (GLIBC_2.0) => /lib/libm.so.6
libpthread.so.0 (GLIBC_2.1) => /lib/libpthread.so.0
libpthread.so.0 (GLIBC_2.3.2) => /lib/libpthread.so.0
libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
libc.so.6 (GLIBC_2.7) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/lib/libdl.so.2:
ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
/usr/lib/libglapi.so.0:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
/usr/lib/libXext.so.6:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
/usr/lib/libXdamage.so.1:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libXfixes.so.3:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libXxf86vm.so.1:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libX11-xcb.so.1:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
/usr/lib/libX11.so.6:
libdl.so.2 (GLIBC_2.1) => /lib/libdl.so.2
libdl.so.2 (GLIBC_2.0) => /lib/libdl.so.2
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libxcb-glx.so.0:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
/usr/lib/libxcb.so.1:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libdrm.so.2:
librt.so.1 (GLIBC_2.2) => /lib/librt.so.1
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
libc.so.6 (GLIBC_2.7) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libXau.so.6:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
/usr/lib/libXdmcp.so.6:
libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
User avatar
TheDoctor
Smokin' Amigo!
 
Posts: 760
Joined: Sun Jun 06, 2010 3:31 am



Postby hellraiser » Tue Nov 01, 2011 6:58 pm

thanks :)
hellraiser
Quick Draw
 
Posts: 63
Joined: Sun Jul 03, 2011 2:37 pm
Location: Italy



Re: Smokin' guns dependencies needed in linux

Postby hellraiser » Sat Feb 09, 2013 3:27 pm

OK thenks!

They're the same also for x86_64 version, right? Probably a stupid question.... :oops: :oops:
hellraiser
Quick Draw
 
Posts: 63
Joined: Sun Jul 03, 2011 2:37 pm
Location: Italy




Return to Telegraph Station

Show Sidebar
Show Sidebar

User Control Panel