With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
Game server information & questions.

Moderators: Pardner, Joe Kari, TheDoctor

Re: No or bad challenge for your address

Postby TheDoctor » Wed Feb 06, 2013 11:24 pm

Biondo wrote:Sorry. No, it doesn't.

I've now got rid of the challenge code. Does it work now?
Image
User avatar
TheDoctor
Smokin' Amigo!
 
Posts: 760
Joined: Sun Jun 06, 2010 3:31 am



Re: No or bad challenge for your address

Postby Biondo » Wed Feb 06, 2013 11:30 pm

No. Sorry.
User avatar
Biondo
SG Website Designer
 
Posts: 533
Joined: Thu Oct 15, 2009 4:35 pm



Re: No or bad challenge for your address

Postby Biondo » Wed Feb 06, 2013 11:32 pm

@TheDoctor: I'm in Jabber ATM, if you need a quick feedback.
User avatar
Biondo
SG Website Designer
 
Posts: 533
Joined: Thu Oct 15, 2009 4:35 pm



Re: No or bad challenge for your address

Postby TheDoctor » Wed Feb 06, 2013 11:42 pm

Biondo wrote:@TheDoctor: I'm in Jabber ATM, if you need a quick feedback.

psi crashes after some seconds and kopete crashed as soon as I tried to configure Jabber.
Image
User avatar
TheDoctor
Smokin' Amigo!
 
Posts: 760
Joined: Sun Jun 06, 2010 3:31 am



Re: No or bad challenge for your address

Postby *lame* jesse james » Wed Feb 06, 2013 11:49 pm

Ok as you saw I could connect on BB, so hope the problem is solved, hope we don't have a second Monsterbrowser-incident, it would not be good for SG players and the future.
Yep I was "banned" from the server, very strange.
*lame* jesse james
Drifter
 
Posts: 8
Joined: Tue Dec 11, 2012 12:30 am



Re: No or bad challenge for your address

Postby Biondo » Wed Feb 06, 2013 11:53 pm

I still can't connect through XQF (equivalent of Monster Browser, just for Linux), but I'm now able to connect directly through native SG server browser. Don't know if this means something.
User avatar
Biondo
SG Website Designer
 
Posts: 533
Joined: Thu Oct 15, 2009 4:35 pm



Re: No or bad challenge for your address

Postby Biondo » Wed Feb 06, 2013 11:54 pm

TheDoctor wrote:
Biondo wrote:@TheDoctor: I'm in Jabber ATM, if you need a quick feedback.

psi crashes after some seconds and kopete crashed as soon as I tried to configure Jabber.


It's Maya end of the world. Postponed.
User avatar
Biondo
SG Website Designer
 
Posts: 533
Joined: Thu Oct 15, 2009 4:35 pm



Re: No or bad challenge for your address

Postby Tequila » Thu Feb 07, 2013 12:08 am

I though the same than Biondo :mrgreen:

Btw, I saw on our IRC channel that there was between 20 and 30 players online since approximatively 15h today (french our) but there was a "hole" of less than 10 players between 22h00 and 22h30. Maybe this is the sign of a network problem...

Honestly I don't see why so many people had problems but because network problems not related to them directly. Maybe we are under attack ? Is there stupid guys around who maybe try asking for so many "challenge" that most of the time good people oare just forgotten by the engine ? I guess this is possible. Can you check your network traffic TheDoctor ? I'll check mine, but I didn't hear my own server had problems too.

:twisted:

Join Smokin'Guns community on Image
User avatar
Tequila
SG Team
 
Posts: 1087
Joined: Thu Nov 15, 2007 11:33 pm
Location: Montpellier, France



Re: No or bad challenge for your address

Postby Tequila » Thu Feb 07, 2013 12:44 am

Just checked the code on my own for the message "No or bad challenge for your address". This is the server answer when the server has checked its 2048 possible values and didn't find your ip... Sounds like a hold-up for me.
:x

Join Smokin'Guns community on Image
User avatar
Tequila
SG Team
 
Posts: 1087
Joined: Thu Nov 15, 2007 11:33 pm
Location: Montpellier, France



Re: No or bad challenge for your address

Postby TheDoctor » Thu Feb 07, 2013 1:09 am

Regarding the "You are banned from this server." message: this is/was a separated, BB-specific problem and introduced by me shortly before or by my first attempt to disable the authentication mechanism. I don't know what triggered it exactly, but I wasn't able to solve this problem other than to deactivate G_FilterPacket. I remember checking/setting sv_strictAuth "0", g_filterBan "0", g_banIps "" and sv_banFile "0".

Tomorrow I will bring a test server online that will feature some debug code on challenges. For the meantime, both the challenge and the authorize mechanism are temporary disabled, which I think enabled everyone to connect again.
Image
User avatar
TheDoctor
Smokin' Amigo!
 
Posts: 760
Joined: Sun Jun 06, 2010 3:31 am



Re: No or bad challenge for your address

Postby Tequila » Thu Feb 07, 2013 1:40 am

About old remaining binaries using olsolete authorize.smokin-guns.net or update.smokin-guns.net services, I don't think this can be the issue for the "challenge" request. Btw for the one comfortable with editing their hosts file, can you just add the following line.
Code: Select all
91.121.39.115 authorize.smokin-guns.net update.smokin-guns.net

If everything is better after that, then this is the issue... And anyway, you can forget this line in your hosts file, this is what the DNS should have been set to anyway.
:twisted:

Join Smokin'Guns community on Image
User avatar
Tequila
SG Team
 
Posts: 1087
Joined: Thu Nov 15, 2007 11:33 pm
Location: Montpellier, France



Re: No or bad challenge for your address

Postby Mope » Thu Feb 07, 2013 1:50 am

Image

I hope I did it right.
User avatar
Mope
Drifter
 
Posts: 7
Joined: Fri Dec 18, 2009 6:22 pm
Location: Tel Aviv, Israel



Re: No or bad challenge for your address

Postby TheDoctor » Thu Feb 07, 2013 2:18 am

Thanks Biondo and Mope. The data you provide shows, your connections are stable and your routes of communications have very little in common.

@Biondo: Regarding Circus Novus, can you confirm you still cannot connect to this server neither via xqf nor via the in-game browser?
Image
User avatar
TheDoctor
Smokin' Amigo!
 
Posts: 760
Joined: Sun Jun 06, 2010 3:31 am



Re: No or bad challenge for your address

Postby TheDoctor » Thu Feb 07, 2013 2:20 am

Biondo wrote:It's Maya end of the world. Postponed.

Actually, I think it's openssl-1.0.0j.
Image
User avatar
TheDoctor
Smokin' Amigo!
 
Posts: 760
Joined: Sun Jun 06, 2010 3:31 am



Re: No or bad challenge for your address

Postby Slowly John » Thu Feb 07, 2013 8:48 am

jippi-ja-yeah wrote:I got the same error yesterday for one time. :twisted:


... and i am the bad guy here, because: "Banned from the Server" is my welcome-message since yesterday :?

thx to jippie for the forum-tip!
thx to biondo for open this treat!
thx @all for solution-try

your dormant vic (alias slowly)


addendum: i have not changed anything... but just i saw: i just access the server!!! ... & i hope it stays that way... BIG THX

your happier vic (alias slowly)
Last edited by Slowly John on Thu Feb 07, 2013 9:07 am, edited 1 time in total.
User avatar
Slowly John
Drifter
 
Posts: 14
Joined: Sat Nov 14, 2009 11:30 am
Location: germany



PreviousNext

Return to Telegraph Station

Show Sidebar
Show Sidebar

User Control Panel