With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
If you have any trouble with SG, this is the place to ask.

Moderator: Pardner

Postby Ozelot » Fri Dec 18, 2009 8:56 pm

No change - still the same error... :|
User avatar
Ozelot
Drifter
 
Posts: 8
Joined: Thu Dec 17, 2009 5:32 pm



Postby /dev/random » Fri Dec 18, 2009 9:39 pm

Eh, wait! You are certain you told the game not to use OpenAL like Tequila suggested? It shoudln't notify you about the missing libopenal.so then, since it does not load it at all..
User avatar
/dev/random
Smokin' Amigo!
 
Posts: 410
Joined: Thu Jan 22, 2009 1:58 pm



Postby Ozelot » Fri Dec 18, 2009 11:46 pm

Yes, I am certain about that, but it doesn't matter any more because I got SG already up and running - I just downloaded the beta release and now it works smoothly. :) Maybe the problem was that I tried to run the 32bit version on a 64bit system...
User avatar
Ozelot
Drifter
 
Posts: 8
Joined: Thu Dec 17, 2009 5:32 pm



Postby Lucky Luke » Sat Sep 11, 2010 10:21 pm

Hi Tequila!

Impossible to use brightness tool with the new beta. And it's all dark.

[frogs version: J'y vois rien. Le bouton pour augmenter la lumière marche pas. La version normale ne marche plus sous ubuntu. La beta marche, mais c'est tout sombre]

What can i do hombre?
User avatar
Lucky Luke
Pistolero
 
Posts: 33
Joined: Mon Mar 16, 2009 2:12 pm



Postby Grelouk » Sun Sep 12, 2010 12:48 am

Use r_gamma
In console : /r_gamma value
It goes from 0 to 2 or more, just try :)
Grelouk
Jeuxlinux Admin
 
Posts: 25
Joined: Thu May 07, 2009 3:37 pm
Location: France



Postby Lucky Luke » Sun Sep 12, 2010 1:03 am

Hi Grelouk! :)

Merci, but it makes.... nothing.

0, 2, , 10, 20, the same.
User avatar
Lucky Luke
Pistolero
 
Posts: 33
Joined: Mon Mar 16, 2009 2:12 pm



Postby /dev/random » Mon Sep 13, 2010 3:53 pm

Iirc you need to have r_ignorehwgamma set to 0 for the game to control gamma (and drivers and device need to support setting gamma ofc). This should be the default value, but you never know.
User avatar
/dev/random
Smokin' Amigo!
 
Posts: 410
Joined: Thu Jan 22, 2009 1:58 pm



Postby Lucky Luke » Fri Sep 17, 2010 11:38 pm

Not working cowboy
User avatar
Lucky Luke
Pistolero
 
Posts: 33
Joined: Mon Mar 16, 2009 2:12 pm



Postby Tequila » Wed Oct 20, 2010 7:02 pm

:D
Sorry Lucky Luke to come so late. I just got a man on IRC telling about same kind of problem with Ubuntu.

It seems for him Gamma works when in windowed mode. Is that the same for you ?

Btw I managed to help him. He just had to start the game from a console exporting a SDL env var like the following:
Code: Select all
export SDL_VIDEO_X11_NODIRECTCOLOR=1

Can you tell us if it helps you ?
The guy said he has an Ati Radeon card. What is yours ?

8)
User avatar
Tequila
SG Team
 
Posts: 1088
Joined: Thu Nov 15, 2007 11:33 pm
Location: Montpellier, France



Postby Lucky Luke » Wed Oct 20, 2010 11:25 pm

Hi Tequila!

My card is something like this:

Code: Select all
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)


Sorry, i just don't know how to start in windowed mode ... i could try if you explain it to me!

I don't know neither how to sart with your command... it tryed with the console that:

Code: Select all
./smokinguns.i386 export SDL_VIDEO_X11_NODIRECTCOLOR=1

But it made nothing new.

I have yet the new ubuntu (maverick bidule)

Did i mention i'm tired to play in the night? 8)
User avatar
Lucky Luke
Pistolero
 
Posts: 33
Joined: Mon Mar 16, 2009 2:12 pm



Postby Lucky Luke » Wed Oct 20, 2010 11:45 pm

Hi!

Actually, it works better in windowed mode. The light is good, but it's still impossible to change brightness (button still doesn't work).

If i were a mouse, i could play like that...

There is another strange thing:

The game seems to be bugged: there is a mix-up melting-pot weapons (something like an image of a shotgun instead of dynamite, when i switch weapons) (i hope someone is able to understand me, at least myself is)
I downloaded it twice, from too different servers, and the same.
User avatar
Lucky Luke
Pistolero
 
Posts: 33
Joined: Mon Mar 16, 2009 2:12 pm



Postby Biondo » Thu Oct 21, 2010 9:17 am

I can confirm the same problem on my PC (Ubuntu Lucid Lynx, 32bit). There is no way to change brightness, nor through the GUI, nor in console, nor tweaking q3config.cfg.

It's strange that the first time you start the game it is very dark. When you adjust the brightness in GUI nothing happens, but upon restart the gamma is 2.0 (and you cannot revert back to a lower one.)

"export SDL_VIDEO_X11_NODIRECTCOLOR=1" does nothing.
"r_ignorehwgamma" set to 0 does nothing.
User avatar
Biondo
SG Website Designer
 
Posts: 533
Joined: Thu Oct 15, 2009 4:35 pm



Postby Tequila » Thu Oct 21, 2010 11:33 am

Lucky Luke wrote:Hi Tequila!
...
Code: Select all
./smokinguns.i386 export SDL_VIDEO_X11_NODIRECTCOLOR=1



Thx for the tries, but in your console try this:
Code: Select all
export SDL_VIDEO_X11_NODIRECTCOLOR=1
./smokinguns.i386

or
Code: Select all
SDL_VIDEO_X11_NODIRECTCOLOR=1 ./smokinguns.i386


@Biondo & @LuckyLuke:
Another question, do you have enabled 3D-acceleration with the desktop ? I mean are you using "compiz-fusion" ? If yes, try disabling it. Otherwise, can you report the content of your "/etc/X11/xorg.conf" file too ? Thx

8)
User avatar
Tequila
SG Team
 
Posts: 1088
Joined: Thu Nov 15, 2007 11:33 pm
Location: Montpellier, France



Postby Lucky Luke » Thu Oct 21, 2010 1:14 pm

Not working.

I don't have any xorg.conf:
What i have:
Code: Select all
ls /etc/X11
app-defaults             fonts    xinit   Xreset.d    Xsession.d
cursors                  rgb.txt  xkb     Xresources  Xsession.options
default-display-manager  X        Xreset  Xsession    Xwrapper.config


Something is working, only in order to be able to play:
Open the game in windowed mode, and then, go in the option end active "fullscreen". Because it stays with a better brightness (but still impossible to change brightness).

Compiz is off.
User avatar
Lucky Luke
Pistolero
 
Posts: 33
Joined: Mon Mar 16, 2009 2:12 pm



Postby Biondo » Thu Oct 21, 2010 2:30 pm

Thank you, Tequila!

Tequila wrote:
Code: Select all
export SDL_VIDEO_X11_NODIRECTCOLOR=1
./smokinguns.i386


OK, this is what I've done.

Code: Select all
do you have enabled 3D-acceleration with the desktop ? I mean are you using "compiz-fusion" ?


No, I haven't 3D-acceleration enabled.

Otherwise, can you report the content of your "/etc/X11/xorg.conf" file too ?


Here it is (in Ubuntu 10.04 "Lucid Lynx" 32bit):

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "CoreKeyboard"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "it"
# Option "XkbOptions" "lv3:ralt_switch"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ImPS/2"
# Option "ZAxisMapping" "4 5"
# Option "Emulate3Buttons" "true"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Driver "wacom"
# Identifier "stylus"
# Option "Device" "/dev/input/wacom"
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4"# Tablet PC ONLY
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/input/wacom"
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4"# Tablet PC ONLY
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/input/wacom"
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4"# Tablet PC ONLY
#EndSection

Section "Monitor"
Identifier "SyncMaster"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@75" 107.21 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
modeline "1280x768@75" 102.98 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@75" 136.49 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
modeline "1920x1200@60" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
Gamma 1.0
EndSection

Section "Monitor"
Identifier "monitor1"
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Integrated Graphics Controller"
Monitor "SyncMaster"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1920 1200
Modes "1440x900@60" "1600x1024@60" "1440x900@75" "1680x1050@60" "1280x800@60" "1920x1200@60" "1280x768@75" "1280x800@75" "1280x720@60" "1280x768@60" "800x600@60" "800x600@75" "800x600@72" "800x600@56"
EndSubSection
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
# commented out by update-manager, HAL is now used
# Inputdevice "Generic Keyboard"
# commented out by update-manager, HAL is now used
# Inputdevice "Configured Mouse"
# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Device"
Identifier "Intel Corporation Integrated Graphics Controller"
Boardname "intel"
Busid "PCI:0:2:0"
Driver "intel"
Screen 0
Option "DRI" "True"
EndSection

Section "Device"
Identifier "device1"
Boardname "VESA driver (generic)"
Busid "PCI:0:2:1"
Driver "vesa"
Screen 0
EndSection

Section "ServerFlags"
Option "DontZap" "False"
EndSection


I have to say, this is the first time I found a SG's beta version almost usable with my OS/hardware configuration. The last time I downoladed SG 1.1 (it was in July) I had much more troubles with it (excessive light contrast, impossibility to climb ladders in some maps, etc.).

As soon as possible I'll try in another Ubuntu32 machine, and I'll report.

Keep on with the good work and thank you again.
User avatar
Biondo
SG Website Designer
 
Posts: 533
Joined: Thu Oct 15, 2009 4:35 pm



PreviousNext

Return to Doc's Office

Show Sidebar
Show Sidebar

User Control Panel