With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
If you have any trouble with SG, this is the place to ask.

Moderator: Pardner

Re: Monsterbrowser

Postby Bodie » Tue Apr 24, 2012 6:34 am

I think it was simply your 0.8a exe that was at fault when creating proper files in %appdata% or maybe something else in registry.

As soon as I started MB through the debug build (which I unpacked where MB was installed), it made all the things it needed, fixed the contents my %appdata% dir and made my old 0.8a exe work too.

So even the old 0.8a exe now launches fine.

It even works when I remove the %appdata% build, suddenly old 0.8a can create all the files there for itself.

I have no idea what pipe was at fault, but running the debug exe seems to have unclogged it. I can only observe that the problem seems to happen when MB tries to update configs in the old %appdata% (with pre-0.8 contents), that's when it clogs.
SG names: Bodie (aka mS // Donnie).
Admin on Jeuxlinux, RAWHIDE, #sg.wars and some other servers.
User avatar
Bodie
Jeuxlinux Admin
 
Posts: 633
Joined: Thu Mar 26, 2009 7:59 pm



Re: Monsterbrowser

Postby a.k47 » Tue Apr 24, 2012 2:01 pm

Hey folk,
i got my mb work again. I started the .exe file from your zip-file and then there was a massage, that it was updated. Now i can open the new version, the 0.8a one again;)

Thank you very much.

cheers
a.k47
in game: -=LWa.k47=-
admin on:
-Jeuxlinux
-smokin'guns.org BR
-smokin'guns.org Mixed
User avatar
a.k47
Jeuxlinux Admin
 
Posts: 101
Joined: Fri Feb 18, 2011 11:20 am



Re: Monsterbrowser

Postby torhu » Fri Apr 27, 2012 1:49 am

I tested the 0.8a installer on two more XP (SP3 both) installations. No problems.

The .exe file in the installer is identical to the one in the zip file, in fact all the files are identical. And both the installer and the zip file is validated with a checksum, so any corruption should cause an error message when installing or unzipping.

Basically, I don't know what causes this issue. But I assume most XP users are not having problems. The test version I posted changes a couple of things that probably won't matter, but I'll leave them in for the next release anyway. At least it will print an error message if there is a problem with the permissions or something when it tries to recreate mods.ini.
In game: =SG=monSter
Monster Browser
User avatar
torhu
SG Team
 
Posts: 1113
Joined: Thu Jan 06, 2005 8:12 pm
Location: Norway



Previous

Return to Doc's Office

Show Sidebar
Show Sidebar

User Control Panel