With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
If you have any trouble with SG, this is the place to ask.

Moderator: Pardner

Re: install game on Mac

Postby yankeedoodle » Tue Sep 25, 2012 4:42 pm

Nevermind,

I've found that this game is only for 10.5 or higher,
so I won't be able to play it.
yankeedoodle
Drifter
 
Posts: 12
Joined: Fri Sep 21, 2012 4:35 pm



Re: install game on Mac

Postby knum » Tue Sep 25, 2012 8:54 pm

Tested on Mac OS X Mountain Lion.

Fails to launch with video settings error.
knum
Newcomer
 
Posts: 4
Joined: Tue Sep 25, 2012 8:49 pm



Re: install game on Mac

Postby MrG4F » Sun Oct 14, 2012 9:11 pm

I have downloaded all of the executables and put them into the root file. When I try to start it up, I get the message couldn't load default.cfg Help?
MrG4F
Drifter
 
Posts: 7
Joined: Sat Sep 22, 2012 11:49 pm
Location: Southern California, USA



Re: install game on Mac

Postby knum » Mon Oct 29, 2012 8:39 pm

I believe the issue with the Mac build of Smokin' Guns only affects Lion and Mountain Lion.

"CGDisplayBaseAddress is obsolete and returning NULL for display 0x42486c0"

Apparently the issue is with SDL. The stable release has the issue but the most recent development release does not.

Hopefully, this helps solve the issue.
knum
Newcomer
 
Posts: 4
Joined: Tue Sep 25, 2012 8:49 pm



Re: install game on Mac

Postby MrG4F » Wed Oct 31, 2012 6:59 am

knum wrote:Apparently the issue is with SDL. The stable release has the issue but the most recent development release does not.


What is the SDL and what is the most recent development release that is functioning?
MrG4F
Drifter
 
Posts: 7
Joined: Sat Sep 22, 2012 11:49 pm
Location: Southern California, USA



Re: install game on Mac

Postby knum » Fri Nov 02, 2012 1:35 am

Latest stable libsdl is 1.2.15-1. This was released at the end of January.

I believe that development of this version has stopped due to the development of libsdl 2.0, which is the unstable branch.

Is Smokin' Guns using the latest stable release of libsdl 1.2?

Other games using libsdl, such as Open Arena, don't have this issue.

Open Arena is using libsdl 1.2.0 that was released at the latest in December 2011 given the build date of the package in Open Arena.

I checked the OS Independent archive of Smokin' Guns 1.1; it appears the libsdl build in Smokin' Guns is from at most October 2009.
knum
Newcomer
 
Posts: 4
Joined: Tue Sep 25, 2012 8:49 pm



Re: install game on Mac

Postby TheDoctor » Sat Oct 05, 2013 4:38 pm

Bumping this post to notify you of a new Smokin' Guns .DMG file for installation on MAC OS X. If you never got SG working or are interested to test this file, give it a try and give us feedback in the above post.
Image
User avatar
TheDoctor
Smokin' Amigo!
 
Posts: 754
Joined: Sun Jun 06, 2010 3:31 am



Previous

Return to Doc's Office

Show Sidebar
Show Sidebar

User Control Panel