With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
Post feedback & meet new friends. General SG discussion.

Moderators: Pardner, TheDoctor

loading time and strange commands

Postby sunrise » Thu Mar 08, 2012 12:04 am

Since 1.1b4 and 1.1b5 are using the same q3 config, i got fps troubles on 1.1b4.
In order to fix it i deleted my old config and changed my settings back to default, but i still got some fps drops up to 30 from my normal 125.
So i experimented and googled, i changed light settings to vertex and found those four commands(vm_cgame / vm_game / vm_ui and cg_brassTime) here (http://quake3tweaks.tripod.com/commands.html), as recommended i set all to "0" even if i dont use any of these mentioned speed dll's.
I know what cg_brassTime does, but i couldn't find the function of the other 3.
Btw it reduced my loading time from 10s to 3s with the 1.1b4 and still with high light settings i only need 3 or 4 seconds to load.
So im wondering what the effect of vm_cgame / vm_game / vm_ui is.
Does anybody know?
sunrise
Pistolero
 
Posts: 49
Joined: Wed Jun 16, 2010 6:05 pm



Re: loading time and strange commands

Postby /dev/random » Thu Mar 08, 2012 10:44 pm

It causes the game engine to try loading native libraries (.dll, .so, .dylib) instead of QVM modules for all the gamecode parts, that is cgame, game and ui (hence the 3 vm_* variables).

That's mostly of interest for debugging reasons, if you actually have your own native libraries for testing. Apart from that there's no real use for it, since SG uses QVMs. Besides you would not be able to play on any of the pure online servers with native libraries.
User avatar
/dev/random
Smokin' Amigo!
 
Posts: 410
Joined: Thu Jan 22, 2009 1:58 pm




Return to Saloon

Show Sidebar
Show Sidebar

User Control Panel