With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
If you have any trouble with SG, this is the place to ask.

Moderator: Pardner

SG Not Working after OpenSUSE Reinstall.

Postby sTony » Tue Mar 03, 2009 11:06 am

Hi all, I sure hope someone can help me, because I just love this game. I'm running OpenSUSE 11.0, and my HD failed a couple of days ago. No biggie, I knew it was comming so I had all my important data backed up. Anyhow, I bought a new HD, reinstalled OpenSUSE, added your great game from the Repos, and it didn't work!!! It worked perfectly before, and I didn't have to do anything special to get it to work. It just worked. I had way more software installed before though, so I'm thinking that maybe I'm missing something that needs to be there. Anyhow, I ran it from a terminal and this is the output that I get.

ln: target `/usr/share/games/smokinguns/westernq3/hangemhigh_readme.txt' is not a directory
UID 0 EUID 0
SG 1.0 linux-i386 Dec 31 2008
----- FS_Startup -----
backwater has checksum 1623748367
coyotebluff has checksum 2953459640
lake has checksum 465789212
train has checksum 2721494609
wq3_maps0 has checksum 1536923698
wq3_maps1 has checksum 3849958775
wq3_pak0 has checksum 1624030397
wq3_pak1 has checksum 1942163816
wq3_pak2 has checksum 3525732908
wq3_pak3 has checksum 1881361774
wq3_sounds0 has checksum 3278800843
wq3_sounds1 has checksum 2605991739
wq3_textures0 has checksum 1279901149
wq3_textures1 has checksum 920604252
wq_hangemhigh has checksum 462480225
Current search path:
/root/.smokinguns/westernq3/wq_hangemhigh.pk3 (40 files)
/root/.smokinguns/westernq3/wq3_textures1.pk3 (47 files)
/root/.smokinguns/westernq3/wq3_textures0.pk3 (628 files)
/root/.smokinguns/westernq3/wq3_sounds1.pk3 (28 files)
/root/.smokinguns/westernq3/wq3_sounds0.pk3 (30 files)
/root/.smokinguns/westernq3/wq3_pak3.pk3 (55 files)
/root/.smokinguns/westernq3/wq3_pak2.pk3 (14 files)
/root/.smokinguns/westernq3/wq3_pak1.pk3 (2 files)
/root/.smokinguns/westernq3/wq3_pak0.pk3 (934 files)
/root/.smokinguns/westernq3/wq3_maps1.pk3 (8 files)
/root/.smokinguns/westernq3/wq3_maps0.pk3 (80 files)
/root/.smokinguns/westernq3/train.pk3 (60 files)
/root/.smokinguns/westernq3/lake.pk3 (103 files)
/root/.smokinguns/westernq3/coyotebluff.pk3 (110 files)
/root/.smokinguns/westernq3/backwater.pk3 (120 files)
/root/.smokinguns/westernq3
/usr/games/smokinguns/westernq3
/root/.smokinguns/smokinguns
/usr/games/smokinguns/smokinguns
/root/.q3a/smokinguns
/root/.smokinguns/baseq3
/usr/games/smokinguns/baseq3

----------------------
2259 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
QKEY building random string
QKEY generated
----- Client Initialization Complete -----
----- R_Init -----
...loading opengl32: QGL_Init: Can't load opengl32 from /etc/ld.so.conf or current dir: /root/.smokinguns/opengl32: cannot open shared object file: No such file or directory
failed
...loading libGL.so: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa DRI Intel(R) 845G 20061017 x86/MMX/SSE2
Initializing OpenGL extensions
...GL_S3_s3tc not found
...using GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
XF86 Gamma extension initialized

GL_VENDOR: Tungsten Graphics, Inc
GL_RENDERER: Mesa DRI Intel(R) 845G 20061017 x86/MMX/SSE2
GL_VERSION: 1.3 Mesa 7.0.3
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_cull_vertex GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_3DFX_texture_compression_FXT1 GL_APPLE_client_storage GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_NV_vertex_program1_1 GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 4

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: disabled
Initializing Shaders
...loading 'scripts/wq_hangemhigh.shader'
...loading 'scripts/base_light.shader'
...loading 'scripts/liquid.shader'
...loading 'scripts/common.shader'
...loading 'scripts/spoon.shader'
...loading 'scripts/western.shader'
...loading 'scripts/frag.shader'
...loading 'scripts/unlagged.shader'
...loading 'scripts/gfx.shader'
...loading 'scripts/hud.shader'
...loading 'scripts/sfx.shader'
...loading 'scripts/weapons.shader'
...loading 'scripts/weapon_fx.shader'
...loading 'scripts/wqfx.shader'
...loading 'scripts/wq_train.shader'
...loading 'scripts/wq_lake.shader'
...loading 'scripts/danight.shader'
...loading 'scripts/dash_skybox1.shader'
...loading 'scripts/wq_coyotebluff.shader'
...loading 'scripts/backwater.shader'
...loading 'scripts/excerpt_sockisland.shader'
...loading 'scripts/oak.shader'
----- finished R_Init -----
------ Initializing Sound ------
smokinguns: pcm_pulse.c:275: pulse_write: Assertion `pcm->last_size >= (size * pcm->frame_size)' failed.
Received signal 6, exiting...
Allocated 96 sources.
OpenAL info:
Vendor: OpenAL Community
Version: 1.1 ALSOFT 1.6.372
Renderer: OpenAL Soft
AL Extensions: AL_EXTX_buffer_sub_data AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_OFFSET AL_LOKI_quadriphonic
ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_EFX
Device: ALSA Software on default
Available Devices:
ALSA Software on default
ALSA Software on Intel 82801DB-ICH4
ALSA Software on Intel 82801DB-ICH4 Modem
OSS Software
Wave File Writer
Sound initialization successful.
--------------------------------
Loading vm file vm/ui.qvm.
VM file ui compiled to 679588 bytes of code
ui loaded in 3124128 bytes on the hunk
trying menu/art/fx_base.TGA...
trying menu/art/fx_red.TGA...
trying menu/art/fx_yel.TGA...
trying menu/art/fx_grn.TGA...
trying menu/art/fx_teal.TGA...
trying menu/art/fx_blue.TGA...
trying menu/art/fx_cyan.TGA...
trying menu/art/fx_white.TGA...
trying gfx/2d/crosshairb.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshairb.tga' in shader 'gfx/2d/crosshairb'
^3Shader gfx/2d/crosshairb has a stage with no image
trying gfx/2d/crosshairc.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshairc.tga' in shader 'gfx/2d/crosshairc'
^3Shader gfx/2d/crosshairc has a stage with no image
trying gfx/2d/crosshaird.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshaird.tga' in shader 'gfx/2d/crosshaird'
^3Shader gfx/2d/crosshaird has a stage with no image
trying gfx/2d/crosshaire.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshaire.tga' in shader 'gfx/2d/crosshaire'
^3Shader gfx/2d/crosshaire has a stage with no image
trying gfx/2d/crosshairf.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshairf.tga' in shader 'gfx/2d/crosshairf'
^3Shader gfx/2d/crosshairf has a stage with no image
trying gfx/2d/crosshairg.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshairg.tga' in shader 'gfx/2d/crosshairg'
^3Shader gfx/2d/crosshairg has a stage with no image
trying gfx/2d/crosshairh.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshairh.tga' in shader 'gfx/2d/crosshairh'
^3Shader gfx/2d/crosshairh has a stage with no image
trying gfx/2d/crosshairi.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshairi.tga' in shader 'gfx/2d/crosshairi'
^3Shader gfx/2d/crosshairi has a stage with no image
trying gfx/2d/crosshairj.TGA...
^3WARNING: R_FindImageFile could not find 'gfx/2d/crosshairj.tga' in shader 'gfx/2d/crosshairj'
^3Shader gfx/2d/crosshairj has a stage with no image
Parsing menu file:ui/main.menu
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 41
Minor opcode of failed request: 0
Serial number of failed request: 60

Any Ideas? What do i need to do to get this working? Your game is so good, I consider this very important to fix.

Thanks in advance,

sTony
sTony
Newcomer
 
Posts: 1
Joined: Mon Feb 23, 2009 2:16 pm



Postby ReD NeCKersoN » Tue Mar 03, 2009 4:33 pm

What's with all of the references to westernq3? Try a fresh install of SG instead of what you're trying to do.
Image
User avatar
ReD NeCKersoN
SG Team
 
Posts: 3245
Joined: Wed Mar 27, 2002 6:22 am
Location: VA, USA



Postby Breli » Tue Mar 03, 2009 5:36 pm

Hi sTony and welcome here :) ... I am all with Red here. Looks like you are trying to install the old mod version. Get a fresh download and take it from there ...
SG name: =SG= BRELI

Harmonica: Did you bring a horse?
Gunmen: Looks like we are short on one horse!
Harmonica: No. You brought two too many.
User avatar
Breli
SG Team
 
Posts: 894
Joined: Mon Jul 18, 2005 10:08 am
Location: Germany



Re: SG Not Working after OpenSUSE Reinstall.

Postby Pardner » Tue Mar 03, 2009 5:39 pm

sTony wrote:/root/.smokinguns/westernq3/wq_hangemhigh.pk3 (40 files)
/root/.smokinguns/westernq3/wq3_textures1.pk3 (47 files)
/root/.smokinguns/westernq3/wq3_textures0.pk3 (628 files)
/root/.smokinguns/westernq3/wq3_sounds1.pk3 (28 files)
/root/.smokinguns/westernq3/wq3_sounds0.pk3 (30 files)
/root/.smokinguns/westernq3/wq3_pak3.pk3 (55 files)
/root/.smokinguns/westernq3/wq3_pak2.pk3 (14 files)
/root/.smokinguns/westernq3/wq3_pak1.pk3 (2 files)
/root/.smokinguns/westernq3/wq3_pak0.pk3 (934 files)
/root/.smokinguns/westernq3/wq3_maps1.pk3 (8 files)
/root/.smokinguns/westernq3/wq3_maps0.pk3 (80 files)
/root/.smokinguns/westernq3/train.pk3 (60 files)
/root/.smokinguns/westernq3/lake.pk3 (103 files)
/root/.smokinguns/westernq3/coyotebluff.pk3 (110 files)
/root/.smokinguns/westernq3/backwater.pk3 (120 files)

Them are the 2.2b files from WesternQuake3 8O Make sure you grabbed the correct files, a re-install should do the trick especially since it was working before.

Image
Image
User avatar
Pardner
SG Team
 
Posts: 1786
Joined: Fri Nov 18, 2005 5:48 am
Location: MD, USA



Postby /dev/random » Wed Mar 04, 2009 4:03 pm

Do you have 3D-accelaration running? It can't load OpenGL, which usually indicates that your graphics drivers are not installed properly.
User avatar
/dev/random
Smokin' Amigo!
 
Posts: 410
Joined: Thu Jan 22, 2009 1:58 pm




Return to Doc's Office

Show Sidebar
Show Sidebar

User Control Panel