With cordite in the air, splintered steel, shell casings and powder burns, there’s only one explanation...
If you have any trouble with SG, this is the place to ask.

Moderator: Pardner

clicking both mouse buttons under linux

Postby findecanno » Fri Oct 23, 2009 2:08 pm

I have a problem with clicking both mouse buttons at once while playing smokin guns under linux. My linux verson is linux mint 7 which is based on ubuntu 9.04. I played the game on my windows partition and have no problems at all. ive had this same problem with other linux games. has anyone else had this problem and knows of a workaround? I love hat this game is cross-platform and would like to play it on linux again.

-thanks
findecanno
Newcomer
 
Posts: 4
Joined: Thu Oct 22, 2009 2:35 pm



Postby yap » Fri Oct 23, 2009 3:02 pm

You're not very clear about what the "the problem" is... Is it that nothing happens if you press both buttons? If so, then probably 3-button-emulation is enabled. I've had the same problem long time ago and disabled the emulation within xorg.conf. However, this seems not to work for everyone, but here is yet another solution...

Good luck!
User avatar
yap
Pistolero
 
Posts: 35
Joined: Sat Jan 03, 2009 10:21 am
Location: Germany



Postby findecanno » Sat Oct 24, 2009 1:28 am

sorry for not being clear I was posting from school and was in a big hurry. Yes my problem is that when I duel wield pistols under Linux I cant fire them both at once. I will check out the solution the next time im on linux.
findecanno
Newcomer
 
Posts: 4
Joined: Thu Oct 22, 2009 2:35 pm



Postby gunsmoker » Tue Jan 19, 2010 6:18 am

Hi, I had that same problem. For me I found a REALLY simple fix:

I push clicked the scroll wheel (between the left and right mouse buttons) once. Then after that I could dual shoot pistols at same time.

Hope that works for you too.
gunsmoker
Pistolero
 
Posts: 25
Joined: Sat Nov 21, 2009 7:44 pm



Postby zed » Tue Feb 16, 2010 2:38 am

The described problem could be related to the emulation of a 3rd mouse button of the X server: if mouse1 and mouse2 are pressed simultaneously, a mouse3 event is generated instead :lol:.

To disable this behavior, depending on what is used by your distribution, either modify the input device section of /etc/X11/xorg.conf
Code: Select all
Section "InputDevice"
        Identifier      "GenericNameOfYourMouse"
        :                       
        Option  "Emulate3Buttons" "false"


or modify the corresponding hal policy file, e.g. /etc/hal/fdi/policy/10-x11-input.fdi
Code: Select all
<match key="info.capabilities" contains="input.mouse">
    :
   <merge key="input.x11_options.Emulate3Buttons" type="string">false</merge>
</match>


If this sounds too complicated, you can try to bind both attacks to your 3rd mouse button by typing
Code: Select all
bind MOUSE3 "+attack;+button6"

either in SG's console or by inserting that line into ~/.smokinguns/smokinguns/autoexec.cfg (you may have to create that file).
zed
Drifter
 
Posts: 9
Joined: Wed Dec 02, 2009 3:54 pm




Return to Doc's Office

Show Sidebar
Show Sidebar

User Control Panel